
  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.tbnweekly.com/content/tncms/live/" />
<meta name="keywords" content="clearwater police, animal cruelty, family cat, felony, u.s. immigration and customs enforcement" />
<meta name="news_keywords" content="clearwater police, animal cruelty, family cat, felony, u.s. immigration and customs enforcement" />
<meta name="description" content="CLEARWATER &mdash; Police arrested a 22-year-old Clearwater man about 9:30 a.m. April 23 for animal cruelty in connection with an incident involving the family&rsquo;s cat." />
<meta name="author" content="TAMPA BAY NEWSPAPERS STAFF" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.tbnweekly.com/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=480%2C600" />
<meta property="og:image:width" content="480" />
<meta property="og:image:height" content="600" />
<meta property="og:title" content="Clearwater man charged with felony animal cruelty" />
<meta property="og:description" content="CLEARWATER &mdash; Police arrested a 22-year-old Clearwater man about 9:30 a.m. April 23 for animal cruelty in connection with an incident involving the family&rsquo;s cat." />
<meta property="og:site_name" content="TBNweekly" />
<meta property="og:section" content="Crime, Crashes and Fires" />
<meta property="article:publisher" content="https://www.facebook.com/TBNweekly/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@TBNwebmaster" />
<meta name="twitter:image:alt" content="Clearwater man charged with felony animal cruelty" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.d6ec438b72ee52ec8fe548e063ecff7a.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-classifieds-bulletins.a78f8be1f6e0dabcb5acb9a8939501f8.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.165.0"},"page":{"grid":"simple","style":"default","path":"\/pinellas_county\/crime_crashes_fire","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"TAMPA BAY NEWSPAPERS STAFF","id":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0","app":"editorial"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":324},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-132810609-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.caf244e2614d000b4f73058e1c610d12.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/ads/impressions.js?_dc=1587699327"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/ads/traffic.js?_dc=1587616528"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/ads/settings.js?_dc=1523641671"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/ads/fixed-big-ad-top-asset/1.js?_dc=1587401147"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/ads/fixed-big-ad-bottom-asset/1.js?_dc=1586452919"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1586975200"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/ads/fixed-big-ad-middle/1.js?_dc=1587657099"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/ie.grid.placement.8d31e32afeebe4520bfab9638ef91435.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>Clearwater man charged with felony animal cruelty | Crime, Crashes and Fires | tbnweekly.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #1B62B7; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #fff; } .fixed-nav #main-navigation { background-color: #fff !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer { background-color: #1B62B7; color: #fff; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #1B62B7; } .navbar-toggle .icon-bar { background-color: #1B62B7 !important; } .navbar-toggle .sr-only-show { color: #1B62B7 !important; } #site-top-nav .list-inline>li>a { color: #1B62B7; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header { background-color: #1B62B7; background-size: cover; background-position: 50% 0; }@media screen and (min-width: 992px) {#site-header { background-image: url(https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/530e006a-89ad-11e7-a9c7-c36310e1e4d0.jpg?resize=1200%2C268) }}@media screen and (min-width: 1200px) {#site-header { background-image: url(https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/530e006a-89ad-11e7-a9c7-c36310e1e4d0.jpg?resize=1700%2C380) }}/* remove full span bgs */ #site-navbar-container, #site-header-container, #site-top-nav-container { background-color: transparent !important; background-image: none !important; }/* remove full span bgs */ #site-footer-container { background-color: transparent !important; background-image: none !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #1B62B7; } }#site-top-nav .list-inline>li>a.btn:not(.btn-link) { color: #fff; }#site-copyright a, #site-footer a { color: #fff; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ /* Hide terms & privacy link on sign up form - BC */ div.panel-footer.user-signup.text-muted > p:nth-child(2){display:none;} /* Site Styles */ .btn-primary {background:rgba(27,98,183, 0.9); border-color:rgba(27,98,183, 0.9);} .btn-primary:hover, .btn-primary:focus, .btn-primary:visited {background:rgba(27,98,183, 1); border-color:rgba(27,98,183, 1);} .blocktitle-custom {margin-bottom: -10px;} #main-page-container .block {margin-bottom: 15px;} /* Header */ #masthead-col-one {width:60%; padding:0;} #masthead-col-two {width:40%; padding:0;} /* Body */ .slideshow-carousel-container .owl-stage-outer {height:auto;} .headline-list .card-meta {display:none;} .headline-list .card-headline>h4 {margin:0;} .drawer-open .offcanvas-close-btn {background:none!important;} .panel {border:none; box-shadow:none;} .block-title {background:#1B62B7;} .block-title .block-title-inner, .user-header .user-header-inner {padding:5px; color:#fff;} .block-title .block-title-inner * {color:#fff!important;} .breadcrumb {margin-right:10px;} .breadcrumb>.active {color: #fff!important;} /* Footer */ #site-copyright a {color:#1B62B7;} /* Media Queries */ @media (max-width:991px) { #main-navigation {background-color:#1B62B7;} .navbar-toggle .icon-bar {background-color:#fff!important;} .navbar-brand img {max-height:45px; margin-top:-11px;} } @media (min-width:992px) and (max-width:1199px) { .navbar-nav>li>a {padding:15px 6px;} } </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.tbnweekly.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//s.yimg.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Clearwater man charged with felony animal cruelty | Crime, Crashes and Fires | tbnweekly.com" href="http://www.tbnweekly.com/search/?f=rss&amp;t=article&amp;c=pinellas_county/crime_crashes_fire&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.tbnweekly.com/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" />
            
    <script defer src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
            
        </head>
        <body class="app-editorial grid-simple blox-asset uuid-6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0 section-pinellas-countysection-crime-crashes-fire type-article infinity-disabled" data-path="/pinellas_county/crime_crashes_fire">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.tbnweekly.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.165.0&tncms.page.grid=simple&tncms.page.style=default&tncms.page.path=%2Fpinellas_county%2Fcrime_crashes_fire&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=TAMPA+BAY+NEWSPAPERS+STAFF&tncms.asset.id=6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0&tncms.asset.app=editorial&tncms.vendor.outbrain=Headlines+and+photo+grid&tncms.vendor.taboola=&tncms.ad.vendor=blox&tncms.system.render_time=324&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.google.ua=UA-132810609-1&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.tbnweekly.com",
  secureDomain: "tbnweekly.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/pinellas_county\/crime_crashes_fire","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container">

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/local_news/"  class="nav-link tnt-section-more-local-news">More Local News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/calendar/community_calendar/"  class="nav-link tnt-section-community-calendar">Community Calendar</a>
                                </li><li>
                                    <a href="/business/"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a href="/schools/"  class="nav-link tnt-section-schools">Schools</a>
                                </li><li>
                                    <a href="/health"  class="nav-link tnt-section-health">Health</a>
                                </li><li>
                                    <a href="/pets"  class="nav-link tnt-section-pets">Pets</a>
                                </li><li>
                                    <a href="/outdoors/"  class="nav-link tnt-section-outdoors">Outdoors</a>
                                </li><li>
                                    <a href="/faith_and_family/"  class="nav-link tnt-section-faith-and-family">Faith and Family</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a href="/opinion/columnists/"  class="nav-link tnt-section-columnists">Columnists</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/photo_galleries"  class="nav-link tnt-section-photo-galleries">Photo Galleries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/announcements/"  class="nav-link tnt-section-announcements">Announcements</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/announcements/anniversaries/"  class="nav-link tnt-section-anniversaries">Anniversaries</a>
                                </li><li>
                                    <a href="/announcements/engagements/"  class="nav-link tnt-section-engagements">Engagements</a>
                                </li><li>
                                    <a href="/announcements/weddings/"  class="nav-link tnt-section-weddings">Weddings</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/special_sections/"  class="nav-link tnt-section-special-sections">Special Sections</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/special_sections/summer_lifestyles/"  class="nav-link tnt-section-summer-lifestyles">Summer Lifestyles</a>
                                </li><li>
                                    <a href="/special_sections/just_for_women/"  class="nav-link tnt-section-just-for-women">Just for Women</a>
                                </li><li>
                                    <a href="/special_sections/fix_sell/"  class="nav-link tnt-section-fix-it-or-sell-it">Fix It or Sell It</a>
                                </li><li>
                                    <a href="/special_sections/active_living/"  class="nav-link tnt-section-active-living">Active Living</a>
                                </li><li>
                                    <a href="/special_sections/gift_guide/"  class="nav-link tnt-section-holiday-gift-guide">Holiday Gift Guide</a>
                                </li><li>
                                    <a href="/special_sections/welcome_back/"  class="nav-link tnt-section-welcome-back">Welcome Back</a>
                                </li><li>
                                    <a href="/special_sections/back_to_school"  class="nav-link tnt-section-back-to-school">Back to School</a>
                                </li><li>
                                    <a href="/special_sections/discover_pinellas/"  class="nav-link tnt-section-discover-pinellas">Discover Pinellas</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="/place_an_ad/"  class="nav-link tnt-section-place-an-ad">Place an Ad</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/marketplace/"  class="nav-link tnt-section-business-directory">Business Directory</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-580314" class="tncms-block hidden-md hidden-lg"><div id="user-controls-580314" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.tbnweekly.com/users/signup/?referer_url=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.tbnweekly.com/users/login/?referer_url=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.tbnweekly.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-580314').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.tbnweekly.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.tbnweekly.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.tbnweekly.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-580314').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.tbnweekly.com/users/logout/" id="user-logout-form-580314"><input type="hidden" name="referer_url" value="https://www.tbnweekly.com/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="/advertise/"  class="nav-link tnt-section-advertise-with-us">Advertise with Us!</a>
                                </li><li>
                                    <a href="/site/personnel.html"  class="nav-link tnt-section-personnel">Personnel</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/pinellas_county/"  class="nav-link tnt-section-pinellas-county">Pinellas County</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/pinellas_county/crime_crashes_fire/"  class="nav-link tnt-section-crime-crashes-and-fires">Crime, Crashes and Fires</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/beach_beacon/"  class="nav-link tnt-section-beaches">Beaches</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/beaches/st_pete_beach/"  class="nav-link tnt-section-st-pete-beach">St. Pete Beach</a>
                                </li><li>
                                    <a href="/beaches/madeira_beach/"  class="nav-link tnt-section-madeira-beach">Madeira Beach</a>
                                </li><li>
                                    <a href="/beaches/indian_rocks_beach/"  class="nav-link tnt-section-indian-rocks-beach">Indian Rocks Beach</a>
                                </li><li>
                                    <a href="/beaches/treasure_island/"  class="nav-link tnt-section-treasure-island">Treasure Island</a>
                                </li><li>
                                    <a href="/beaches/redington_beach/"  class="nav-link tnt-section-redington-beach">Redington Beach</a>
                                </li><li>
                                    <a href="/beaches/redington_shores/"  class="nav-link tnt-section-redington-shores">Redington Shores</a>
                                </li><li>
                                    <a href="/beaches/indian_shores/"  class="nav-link tnt-section-indian-shores">Indian Shores</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/belleair_bee/"  class="nav-link tnt-section-belleair">Belleair</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/belleair_bee/belleair_bluffs/"  class="nav-link tnt-section-belleair-bluffs">Belleair Bluffs</a>
                                </li><li>
                                    <a href="/belleair_bee/belleair_beach/"  class="nav-link tnt-section-belleair-beach">Belleair Beach</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/clearwater_beacon/"  class="nav-link tnt-section-clearwater">Clearwater</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/clearwater_beacon/safety_harbor/"  class="nav-link tnt-section-safety-harbor">Safety Harbor</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/seminole_beacon/"  class="nav-link tnt-section-seminole">Seminole</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/largo_leader/"  class="nav-link tnt-section-largo">Largo</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-8" data-target="#mobile-nav-right_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/north_county/"  class="nav-link tnt-section-north-county">North County</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a href="/north_county/dunedin_beacon/"  class="nav-link tnt-section-dunedin">Dunedin</a>
                                </li><li>
                                    <a href="/north_county/palm_harbor_beacon/"  class="nav-link tnt-section-palm-harbor">Palm Harbor</a>
                                </li><li>
                                    <a href="/north_county/pinellas_park_beacon/"  class="nav-link tnt-section-pinellas-park">Pinellas Park</a>
                                </li><li>
                                    <a href="/north_county/tarpon_springs_beacon/"  class="nav-link tnt-section-tarpon-springs">Tarpon Springs</a>
                                </li><li>
                                    <a href="/north_county/oldsmar_beacon"  class="nav-link tnt-section-oldsmar">Oldsmar</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-9" data-target="#mobile-nav-right_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/diversions/"  class="nav-link tnt-section-diversions">Diversions</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/calendar/entertainment"  class="nav-link tnt-section-entertainment-calendar">Entertainment Calendar</a>
                                </li><li>
                                    <a href="/diversions/museums_theater/"  class="nav-link tnt-section-museums-stage-theater">Museums, Stage & Theater</a>
                                </li><li>
                                    <a href="/diversions/movie_news/"  class="nav-link tnt-section-movie-news-reviews">Movie News & Reviews</a>
                                </li><li>
                                    <a href="/diversions/music/"  class="nav-link tnt-section-music-concerts">Music & Concerts</a>
                                </li><li>
                                    <a href="/diversions/horoscope/"  class="nav-link tnt-section-horoscope">Horoscope</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-580310" class="tncms-block hidden-md hidden-lg"><section id="block-580310" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-580310" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-580310" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-580310-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-580310-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-580310-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-580310').submit();
        return false;
    });

    $('#site-search-580310').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-580310 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-580310 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-580310-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    

    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-personnel"  href="/site/personnel.html" >
                    <span class="nav-label">Personnel</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise-with-us"  href="/advertise/" >
                    <span class="nav-label">Advertise with Us!</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-580311" class="tncms-block"><div class="follow-links-580311 pull-right">
    
    <section id="block-580311" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/TBNweekly/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/TBNwebmaster/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.tbnweekly.com",
  "sameAs" : ["https://www.facebook.com/TBNweekly/","http://twitter.com/TBNwebmaster/"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-580313" class="tncms-block"><div id="user-controls-580313" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.tbnweekly.com/users/signup/?referer_url=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.tbnweekly.com/users/login/?referer_url=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.tbnweekly.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-580313').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.tbnweekly.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.tbnweekly.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.tbnweekly.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-580313').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.tbnweekly.com/users/logout/" id="user-logout-form-580313"><input type="hidden" name="referer_url" value="https://www.tbnweekly.com/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-644875" class="tncms-block visible-lg visible-md hidden-sm hidden xs">
        <div id="blox-ad-position-micro-bar1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"micro-bar","slot":"1","fold":"above","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-593813" class="tncms-block a"><section id="block-593813" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/5bef7670-a92c-11e7-a77e-3b9a4d103b84.png?resize=200%2C72 200w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/5bef7670-a92c-11e7-a77e-3b9a4d103b84.png?resize=300%2C108 300w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/5bef7670-a92c-11e7-a77e-3b9a4d103b84.png?resize=400%2C144 400w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/5bef7670-a92c-11e7-a77e-3b9a4d103b84.png?resize=540%2C195 540w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/5bef7670-a92c-11e7-a77e-3b9a4d103b84.png?resize=750%2C271 750w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/5bef7670-a92c-11e7-a77e-3b9a4d103b84.png?resize=1200%2C433 1200w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/5bef7670-a92c-11e7-a77e-3b9a4d103b84.png?resize=1700%2C614 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-9 col-sm-9"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-580315" class="tncms-block padding-bottom"><div id="weather-580315" class="weather-current size-large pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=33772" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                        <span class="pull-left btn btn-xs btn-danger weather-alert-btn" data-toggle="tooltip" data-placement="right" title="Weather Alert"><i class="fas tnt-exclamation-triangle"></i></span>
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc large">
                    <span class="temp">79&deg;</span>
                    
                        <span class="cond">Clear <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="33772"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-580315 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Seminole, FL
                                
                                 <small>(33772)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Variable clouds with scattered thunderstorms. A few storms may be severe. High 81F. Winds SW at 10 to 20 mph. Chance of rain 60%. Rainfall possibly over one inch..</p>
                            <h5>Tonight</h5>
                            <p>Variably cloudy with scattered thunderstorms. A few storms may be severe. Low 73F. Winds SSW at 5 to 10 mph. Chance of rain 60%.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: April 23, 2020 @ 11:37 pm</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=33772"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-580309" class="tncms-block padding-top"><section id="block-580309" class="block emphasis-h3   text-shadow " >
        <div class="card-panel panel">
            <div class="panel-body">
    
    <div class="clearfix"></div>
    <div id="search-form-580309" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-580309" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-lg ">
        <input id="site-search-580309-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-580309-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    
            </div>
        </div>
    </section> 

<script>
    $('#site-search-580309-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-580309').submit();
        return false;
    });

    $('#site-search-580309').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-580309 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-580309 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-580309-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop  navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                    
                    
                        <button type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-601675" class="tncms-block m"><section id="block-601675" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/58ea584a-af59-11e7-a501-675ee6b70408.png?resize=200%2C65 200w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/58ea584a-af59-11e7-a501-675ee6b70408.png?resize=300%2C97 300w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/58ea584a-af59-11e7-a501-675ee6b70408.png?resize=400%2C130 400w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/58ea584a-af59-11e7-a501-675ee6b70408.png?resize=540%2C175 540w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/58ea584a-af59-11e7-a501-675ee6b70408.png?resize=750%2C243 750w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/58ea584a-af59-11e7-a501-675ee6b70408.png?resize=1200%2C390 1200w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/custom/image/58ea584a-af59-11e7-a501-675ee6b70408.png?resize=1700%2C552 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise-with-us"  href="/advertise/" >
                    <span class="nav-label">Advertise with Us!</span>
                </a></li><li>
                <a class="nav-link  tnt-section-personnel"  href="/site/personnel.html" >
                    <span class="nav-label">Personnel</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-pinellas-county"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/pinellas_county/" >
                    <span class="nav-label">Pinellas County</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-crime-crashes-and-fires"  href="/pinellas_county/crime_crashes_fire/" >
                    <span class="nav-label">Crime, Crashes and Fires</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-beaches"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/beach_beacon/" >
                    <span class="nav-label">Beaches</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-st-pete-beach"  href="/beaches/st_pete_beach/" >
                    <span class="nav-label">St. Pete Beach</span>
                </a></li><li>
                <a class="nav-link  tnt-section-madeira-beach"  href="/beaches/madeira_beach/" >
                    <span class="nav-label">Madeira Beach</span>
                </a></li><li>
                <a class="nav-link  tnt-section-indian-rocks-beach"  href="/beaches/indian_rocks_beach/" >
                    <span class="nav-label">Indian Rocks Beach</span>
                </a></li><li>
                <a class="nav-link  tnt-section-treasure-island"  href="/beaches/treasure_island/" >
                    <span class="nav-label">Treasure Island</span>
                </a></li><li>
                <a class="nav-link  tnt-section-redington-beach"  href="/beaches/redington_beach/" >
                    <span class="nav-label">Redington Beach</span>
                </a></li><li>
                <a class="nav-link  tnt-section-redington-shores"  href="/beaches/redington_shores/" >
                    <span class="nav-label">Redington Shores</span>
                </a></li><li>
                <a class="nav-link  tnt-section-indian-shores"  href="/beaches/indian_shores/" >
                    <span class="nav-label">Indian Shores</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-belleair"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/belleair_bee/" >
                    <span class="nav-label">Belleair</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-belleair-bluffs"  href="/belleair_bee/belleair_bluffs/" >
                    <span class="nav-label">Belleair Bluffs</span>
                </a></li><li>
                <a class="nav-link  tnt-section-belleair-beach"  href="/belleair_bee/belleair_beach/" >
                    <span class="nav-label">Belleair Beach</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-clearwater"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/clearwater_beacon/" >
                    <span class="nav-label">Clearwater</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-safety-harbor"  href="/clearwater_beacon/safety_harbor/" >
                    <span class="nav-label">Safety Harbor</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-seminole"  href="/seminole_beacon/" >
                    <span class="nav-label">Seminole</span>
                </a></li><li>
                <a class="nav-link  tnt-section-largo"  href="/largo_leader/" >
                    <span class="nav-label">Largo</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-north-county"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/north_county/" >
                    <span class="nav-label">North County</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-dunedin"  href="/north_county/dunedin_beacon/" >
                    <span class="nav-label">Dunedin</span>
                </a></li><li>
                <a class="nav-link  tnt-section-palm-harbor"  href="/north_county/palm_harbor_beacon/" >
                    <span class="nav-label">Palm Harbor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pinellas-park"  href="/north_county/pinellas_park_beacon/" >
                    <span class="nav-label">Pinellas Park</span>
                </a></li><li>
                <a class="nav-link  tnt-section-tarpon-springs"  href="/north_county/tarpon_springs_beacon/" >
                    <span class="nav-label">Tarpon Springs</span>
                </a></li><li>
                <a class="nav-link  tnt-section-oldsmar"  href="/north_county/oldsmar_beacon" >
                    <span class="nav-label">Oldsmar</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-diversions"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/diversions/" >
                    <span class="nav-label">Diversions</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-entertainment-calendar"  href="/calendar/entertainment" >
                    <span class="nav-label">Entertainment Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-museums-stage-theater"  href="/diversions/museums_theater/" >
                    <span class="nav-label">Museums, Stage & Theater</span>
                </a></li><li>
                <a class="nav-link  tnt-section-movie-news-reviews"  href="/diversions/movie_news/" >
                    <span class="nav-label">Movie News & Reviews</span>
                </a></li><li>
                <a class="nav-link  tnt-section-music-concerts"  href="/diversions/music/" >
                    <span class="nav-label">Music & Concerts</span>
                </a></li><li>
                <a class="nav-link  tnt-section-horoscope"  href="/diversions/horoscope/" >
                    <span class="nav-label">Horoscope</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-580202" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-580203" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><div id="modal-image-ae6bb02e-85a4-11ea-a544-bb16b75d63e0" class="modal fullscreen in modal-image image-default modal-ae6bb02e-85a4-11ea-a544-bb16b75d63e0" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-vertical letterbox-style-">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=400%2C500"
                    srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=200%2C250 200w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=300%2C375 300w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=400%2C500 400w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=480%2C600 540w"
                    sizes="100vw"
                    width="480"
                    height="600"
                    alt="Clearwater man charged with felony animal cruelty"
                    class="img-responsive true-size" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-ae6bb02e-85a4-11ea-a544-bb16b75d63e0" data-target=".caption-inner-modal-image-ae6bb02e-85a4-11ea-a544-bb16b75d63e0">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-ae6bb02e-85a4-11ea-a544-bb16b75d63e0 collapse in"><div class="caption-text"><p>Joshua Daniel Pena-Cedillo</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tbnweekly.com%2Fimage_ae6bb02e-85a4-11ea-a544-bb16b75d63e0.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/image_ae6bb02e-85a4-11ea-a544-bb16b75d63e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"ae6bb02e-85a4-11ea-a544-bb16b75d63e0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Clearwater%20man%20charged%20with%20felony%20animal%20cruelty&via=TBNwebmaster&url=https%3A%2F%2Fwww.tbnweekly.com%2Fimage_ae6bb02e-85a4-11ea-a544-bb16b75d63e0.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/image_ae6bb02e-85a4-11ea-a544-bb16b75d63e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"ae6bb02e-85a4-11ea-a544-bb16b75d63e0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.tbnweekly.com/image_ae6bb02e-85a4-11ea-a544-bb16b75d63e0.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/image_ae6bb02e-85a4-11ea-a544-bb16b75d63e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"ae6bb02e-85a4-11ea-a544-bb16b75d63e0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.tbnweekly.com/tncms/asset/editorial/ae6bb02e-85a4-11ea-a544-bb16b75d63e0" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"ae6bb02e-85a4-11ea-a544-bb16b75d63e0"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTBNweekly%5D%20Clearwater%20man%20charged%20with%20felony%20animal%20cruelty&body=https%3A%2F%2Fwww.tbnweekly.com%2Fimage_ae6bb02e-85a4-11ea-a544-bb16b75d63e0.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"ae6bb02e-85a4-11ea-a544-bb16b75d63e0"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/image_ae6bb02e-85a4-11ea-a544-bb16b75d63e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"ae6bb02e-85a4-11ea-a544-bb16b75d63e0"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-ae6bb02e-85a4-11ea-a544-bb16b75d63e0-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="ae6bb02e-85a4-11ea-a544-bb16b75d63e0" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="ae6bb02e-85a4-11ea-a544-bb16b75d63e0" class="save-list-ae6bb02e-85a4-11ea-a544-bb16b75d63e0-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="ae6bb02e-85a4-11ea-a544-bb16b75d63e0" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-ae6bb02e-85a4-11ea-a544-bb16b75d63e0 img { max-height: 600px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" class="asset article-default"  data-url="https://www.tbnweekly.com/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=480%2C600">
            <meta itemprop="width" content="480">
            <meta itemprop="height" content="600">
        </div>
        <meta itemprop="name" content="tbnweekly.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.tbnweekly.com/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" />
    <div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.tbnweekly.com\/tncms\/search\/mlt\/?origin=6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" class="asset-paging">
                <div id="paging-prev-6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" class="paging-link prev offset"></div>
                <div id="paging-next-6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Clearwater man charged with felony animal cruelty
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">By TAMPA BAY NEWSPAPERS STAFF</span></li>
        
        
            <li class="visible-print">
        <time datetime="2020-04-23T16:53:00-04:00" class="tnt-date asset-date text-muted">
            Apr 23, 2020
        </time>
    </li>
            <li class="hidden-print"><time datetime="2020-04-23T16:53:00-04:00" class="tnt-date asset-date text-muted">
            Apr 23, 2020
        </time><span class="text-muted">Updated </span><time datetime="2020-04-23T16:57:41-04:00" class="tnt-date asset-date text-muted">7 hrs ago</time>
    </li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-04-23T16:53:00-04:00">
    <meta itemprop="datePublished" content="2020-04-23T16:53:00-04:00">
    <meta itemprop="dateModified" content="2020-04-23T12:57:41-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Clearwater%20man%20charged%20with%20felony%20animal%20cruelty&via=TBNwebmaster&url=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.tbnweekly.com/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.tbnweekly.com/tncms/asset/editorial/6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTBNweekly%5D%20Clearwater%20man%20charged%20with%20felony%20animal%20cruelty&body=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-vertical hover-expand letterbox-style-"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-ae6bb02e-85a4-11ea-a544-bb16b75d63e0" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-ae6bb02e-85a4-11ea-a544-bb16b75d63e0" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="480">
            <meta itemprop="height" content="600">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg">
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=400%2C500"
                    srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=200%2C250 200w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=300%2C375 300w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=400%2C500 400w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/e6/ae6bb02e-85a4-11ea-a544-bb16b75d63e0/5ea200c90890d.image.jpg?resize=480%2C600 540w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), 100vw"
                    width="480"
                    height="600"
                    alt="Clearwater man charged with felony animal cruelty"
                    class="img-responsive  letterbox tnt-restrict-img-ae6bb02e-85a4-11ea-a544-bb16b75d63e0" />
            </div><style>
                .tnt-restrict-img-ae6bb02e-85a4-11ea-a544-bb16b75d63e0 {
                    max-width: 480px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            <span class="caption-text">
                                <p>Joshua Daniel Pena-Cedillo</p>
                            </span>
                        
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Clearwater%20man%20charged%20with%20felony%20animal%20cruelty&via=TBNwebmaster&url=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.tbnweekly.com/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.tbnweekly.com/tncms/asset/editorial/6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTBNweekly%5D%20Clearwater%20man%20charged%20with%20felony%20animal%20cruelty&body=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" class="save-list-6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>CLEARWATER — Police arrested a 22-year-old Clearwater man about 9:30 a.m. April 23 for animal cruelty in connection with an incident involving the family’s cat.</p><p>Clearwater police responded to a residence on Sedeeva Circle North after Joshua Daniel Pena-Cedillo's stepfather said he found the cat's severed head on a stick in the back yard.</p><p>Officers say Pena-Cedillo told them two versions of how the cat had died, including that he had strangled it and he had placed it alive in a plastic bag and suffocated it.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/pinellas_county\/crime_crashes_fire","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top-asset', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Police say he then told them he had cut off the cat's head with an ax and then tried to impale it on a stick. When that effort failed, he taped the cat's head to a stick.</p><p>Officers say he also cut off the head of a stuffed animal he had had for years and taped it on to another stick. He reportedly said his actions were intended to show “what he was capable of to someone he was living with,” according to police.</p><p>Pena-Cedillo was booked into the county jail on one felony charge of cruelty to animals. Bail was set at $5,000. He also is on hold for U.S. Immigration and Customs Enforcement.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/pinellas_county\/crime_crashes_fire","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom-asset', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Clearwater%20man%20charged%20with%20felony%20animal%20cruelty&via=TBNwebmaster&url=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.tbnweekly.com/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.tbnweekly.com/tncms/asset/editorial/6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTBNweekly%5D%20Clearwater%20man%20charged%20with%20felony%20animal%20cruelty&body=https%3A%2F%2Fwww.tbnweekly.com%2Fpinellas_county%2Fcrime_crashes_fire%2Farticle_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" class="save-list-6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22clearwater%20police%22#tncms-source=keyword" class="tag-clearwater-police label label-default" >Clearwater Police</a>
            </li> <li>
                <a href="/search/?k=%22animal%20cruelty%22#tncms-source=keyword" class="tag-animal-cruelty label label-default" >Animal Cruelty</a>
            </li> <li>
                <a href="/search/?k=%22family%20cat%22#tncms-source=keyword" class="tag-family-cat label label-default" >Family Cat</a>
            </li> <li>
                <a href="/search/?k=%22felony%22#tncms-source=keyword" class="tag-felony label label-default" >Felony</a>
            </li> <li>
                <a href="/search/?k=%22u.s.%20immigration%20and%20customs%20enforcement%22#tncms-source=keyword" class="tag-u_s_-immigration-and-customs-enforcement label label-default" >U.s. Immigration And Customs Enforcement</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div><div class="asset-recommend native-programmatic hidden-print">
    <script id="yap_id1">
        var adUnitCode = adUnitCode || [];
        adUnitCode.push("832ed22d-3ce2-4937-9f93-e56306b8315c");
        var apiKey = "YDC2G9T2K4BXNCJ3XDMR";
        (function () {
            var script = document.createElement("script");
            script.async = true;
            script.src = "https://s.yimg.com/av/yap/ga/yap.js";
            document.body.appendChild(script);
        })();
        var yap_script = document.getElementById('yap_id1');
        var yap_parent_node = yap_script.parentNode;
        var container_yap_div = document.createElement('div');
        container_yap_div.className = 'yap-ad-832ed22d-3ce2-4937-9f93-e56306b8315c';
        yap_parent_node.insertBefore(container_yap_div, yap_script);
    </script>
</div><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/pinellas_county\/crime_crashes_fire","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-666903" class="tncms-block"><section id="block-666903" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-666903 ">
        <div class="block-title-inner">
            <h3>
                
                Latest numbers
                
            </h3>
        </div>
    </div></div><div class="card-grid   card-img-md card-bg-color">
        
        
            <div class=" ">
        
        <div class="  last-grid-item">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-666903-27189b34-85bb-11ea-8a1c-5bc8b42e4eec" class="clearfix card summary has-image image-top inherit  tnt-section-coronavirus">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-27189b34-85bb-11ea-8a1c-5bc8b42e4eec media-preview article-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/coronavirus/article_27189b34-85bb-11ea-8a1c-5bc8b42e4eec.html" class="tnt-asset-link">
                
                
                    <div class="asset-icon"><i class="fas tnt-camera tnt-fw" title="Article with images"></i> +3</div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="DOH reports seven new COVID-19 related deaths in Pinellas this week"
                            class="img-responsive lazyload full"
                            width="1354"
                            height="956"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/91/a9166f80-85bb-11ea-bdcc-5ba1df044ddf/5ea2272b0dd97.image.png?resize=200%2C141 200w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/91/a9166f80-85bb-11ea-bdcc-5ba1df044ddf/5ea2272b0dd97.image.png?resize=300%2C212 300w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/91/a9166f80-85bb-11ea-bdcc-5ba1df044ddf/5ea2272b0dd97.image.png?resize=400%2C282 400w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/91/a9166f80-85bb-11ea-bdcc-5ba1df044ddf/5ea2272b0dd97.image.png?resize=540%2C381 540w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/91/a9166f80-85bb-11ea-bdcc-5ba1df044ddf/5ea2272b0dd97.image.png?resize=750%2C530 750w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/91/a9166f80-85bb-11ea-bdcc-5ba1df044ddf/5ea2272b0dd97.image.png?resize=1200%2C847 1200w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/91/a9166f80-85bb-11ea-bdcc-5ba1df044ddf/5ea2272b0dd97.image.png?resize=1354%2C956 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/coronavirus/article_27189b34-85bb-11ea-8a1c-5bc8b42e4eec.html" class="tnt-asset-link">
        

        
            DOH reports seven new COVID-19 related deaths in Pinellas this week</a></h3></div>
                    
                    
                        <div class="card-social">
                            <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tbnweekly.com%2Fcoronavirus%2Farticle_27189b34-85bb-11ea-8a1c-5bc8b42e4eec.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/coronavirus/article_27189b34-85bb-11ea-8a1c-5bc8b42e4eec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"27189b34-85bb-11ea-8a1c-5bc8b42e4eec"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=DOH%20reports%20seven%20new%20COVID-19%20related%20deaths%20in%20Pinellas%20this%20week&via=TBNwebmaster&url=https%3A%2F%2Fwww.tbnweekly.com%2Fcoronavirus%2Farticle_27189b34-85bb-11ea-8a1c-5bc8b42e4eec.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/coronavirus/article_27189b34-85bb-11ea-8a1c-5bc8b42e4eec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"27189b34-85bb-11ea-8a1c-5bc8b42e4eec"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.tbnweekly.com/coronavirus/article_27189b34-85bb-11ea-8a1c-5bc8b42e4eec.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/coronavirus/article_27189b34-85bb-11ea-8a1c-5bc8b42e4eec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"27189b34-85bb-11ea-8a1c-5bc8b42e4eec"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.tbnweekly.com/tncms/asset/editorial/27189b34-85bb-11ea-8a1c-5bc8b42e4eec" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"27189b34-85bb-11ea-8a1c-5bc8b42e4eec"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTBNweekly%5D%20DOH%20reports%20seven%20new%20COVID-19%20related%20deaths%20in%20Pinellas%20this%20week&body=https%3A%2F%2Fwww.tbnweekly.com%2Fcoronavirus%2Farticle_27189b34-85bb-11ea-8a1c-5bc8b42e4eec.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"27189b34-85bb-11ea-8a1c-5bc8b42e4eec"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
                        </div>
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Two more deaths were reported in Pinellas County Thursday night, bringing the death toll to 23. Florida Department of Health has confirmed seven new COVID-19 related deaths in the county since April 21. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
            
        
        
        
        
        </div>
        </div></section></div><div id="tncms-block-580223" class="tncms-block visible-lg visible-md blocktitle-custom"><section id="block-580223" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-580223 dark">
        <div class="block-title-inner">
            <h4>
                
                Latest News
                
            </h4>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-circle border border-dotted"><li class="">
            <span class="tnt-headline ">
        
             <a href="/coronavirus/article_27189b34-85bb-11ea-8a1c-5bc8b42e4eec.html" class="tnt-asset-link">
        

        
            DOH reports seven new COVID-19 related deaths in Pinellas this week</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/pinellas_county/crime_crashes_fire/article_6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0.html" class="tnt-asset-link">
        

        
            Clearwater man charged with felony animal cruelty</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/coronavirus/article_44d97cd0-8582-11ea-bd22-af72c2e0cdd8.html" class="tnt-asset-link">
        

        
            Pinellas’ COVID-19 case count creeps up to 649: Death toll stands at 21</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/schools/article_5131a898-8570-11ea-b13f-db3a0bf0225e.html" class="tnt-asset-link">
        

        
            Pinellas School Board says yes to vaping lawsuit</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/opinion/article_287902da-84bb-11ea-b30c-7fe8ce381cc5.html" class="tnt-asset-link">
        

        
            Column: Bits and pieces from all over</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/opinion/article_62131986-84bb-11ea-adfa-972fee0f14ad.html" class="tnt-asset-link">
        

        
            Letter: Time to start opening up economy</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/opinion/article_87f96164-84bb-11ea-bafd-a736ca67ebe9.html" class="tnt-asset-link">
        

        
            Letter: General Eisenhower vs. President Trump</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/diversions/article_f36c63e2-80bf-11ea-a483-1b847dde742e.html" class="tnt-asset-link">
        

        
            Opening this weekend: April 23, 2020</a></span>
        </li></ul></div>
        </div></div></section></div><div id="tncms-block-612173" class="tncms-block">
        <div id="blox-ad-position-block-featured-sidebar1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-featured-sidebar","slot":"1","fold":"span","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-644537" class="tncms-block">
        <div id="blox-ad-position-block-featured-sidebar21" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-featured-sidebar2","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-580262" class="tncms-block"><section id="block-580262" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-580262 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-580262" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-580262" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
        
        
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-580262" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/coronavirus/article_9e89b8d6-8018-11ea-8be2-5b6e52cc97c9.html">Local state of emergency extended: Pinellas beaches and pools to remain closed</a></li><li><a href="/coronavirus/article_67db1aa4-81b8-11ea-9c90-234cba0afd51.html">Governor says Florida schools will remain closed for the rest of the year</a></li><li><a href="/pinellas_county/crime_crashes_fire/article_5947b7b0-8053-11ea-b4cc-3bdf96afa29e.html">Pinellas deputies make arrest for violation of safer-at-home order</a></li><li><a href="/coronavirus/article_39da4040-8437-11ea-978f-cb760485e136.html">Pinellas extends local state of emergency with no changes in restrictions</a></li><li><a href="/coronavirus/article_6bfbe2d2-8350-11ea-86dc-0bf0f43c56d7.html">Palm Harbor nursing facility reports outbreak of coronavirus</a></li><li><a href="/clearwater_beacon/article_07b9ecb0-81bb-11ea-bea8-3ffde0a16f88.html">Despite church members’ pleas, city appoints Scientology critic to downtown board</a></li><li><a href="/coronavirus/article_a057a8ba-81c8-11ea-b1e0-6baf05346a5b.html">DOH reports 22 new cases of COVID-19 in 24 hours in Pinellas</a></li><li><a href="/coronavirus/article_85a88038-8106-11ea-804d-f7bb22b3152c.html">Three residents of Seminole nursing home dead from coronavirus</a></li><li><a href="/pinellas_county/crime_crashes_fire/article_d882d46e-834c-11ea-baa4-3b00ea0ac805.html">Amazon delivery driver accused of burglarizing vehicles</a></li><li><a href="/coronavirus/article_c1dcbd4a-8196-11ea-a320-4b8c60e6786e.html">Another 12 cases of COVID-19 in Pinellas: Death toll stands at 16</a></li></ul></div>
        
        
            <div id="images-580262" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_a345efc2-784b-11ea-850b-974bf8d421c1.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Pinellas County employee tests positive for COVIID-19"
                            class="img-responsive lazyload full"
                            width="242"
                            height="242"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/a/34/a345efc2-784b-11ea-850b-974bf8d421c1/5e8b9bd12fbf9.image.jpg?crop=242%2C242%2C79%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_22d06340-801b-11ea-85ad-a7cb056f9f8f.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Local state of emergency extended: Pinellas beaches and pools to remain closed"
                            class="img-responsive lazyload full"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/2/2d/22d06340-801b-11ea-85ad-a7cb056f9f8f/5e98b707875ac.image.jpg?crop=1175%2C1175%2C294%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_40c77aa8-782f-11ea-a2ff-93989ac8483c.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="St. Petersburg, Clearwater, Largo are Pinellas’ coronavirus hotspots"
                            class="img-responsive lazyload full"
                            width="956"
                            height="956"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/4/0c/40c77aa8-782f-11ea-a2ff-93989ac8483c/5e8b6c46b0443.image.png?crop=956%2C956%2C199%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_59b32270-7379-11ea-972b-db5fb9cc42c3.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="n-CV-Belleair3-040220.JPG"
                            class="img-responsive lazyload full"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/5/9b/59b32270-7379-11ea-972b-db5fb9cc42c3/5e8384fa271df.image.jpg?crop=1175%2C1175%2C294%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_28580592-7ddd-11ea-8363-bf201899f873.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="doh-chart-pinellas-4-13-pm.jpg"
                            class="img-responsive lazyload full"
                            width="740"
                            height="740"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/2/85/28580592-7ddd-11ea-8363-bf201899f873/5e94f3649b277.image.jpg?crop=740%2C740%2C151%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_1aa3293c-7d00-11ea-bc93-6fa04ec98bbc.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Pinellas residents ask what it will take to get back to normal"
                            class="img-responsive lazyload full"
                            width="487"
                            height="487"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/1/aa/1aa3293c-7d00-11ea-bc93-6fa04ec98bbc/5e9380ba5a98b.image.jpg?crop=487%2C487%2C125%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_9f3aaf18-736d-11ea-b700-17b2380e2205.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="DOH reports 144 cases of coronavirus in Pinellas"
                            class="img-responsive lazyload full"
                            width="956"
                            height="956"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/9/f3/9f3aaf18-736d-11ea-b700-17b2380e2205/5e837167ac1eb.image.png?crop=956%2C956%2C199%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_74e8d13e-8003-11ea-b26b-8fa8a49a48ba.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="covid-update.png"
                            class="img-responsive lazyload full"
                            width="956"
                            height="956"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/7/4e/74e8d13e-8003-11ea-b26b-8fa8a49a48ba/5e988ea449ff1.image.png?crop=956%2C956%2C199%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_31b71a90-6ebc-11ea-be18-2f3a8c681cd4.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Coronavirus cases in Pinellas climb up to 50 as of March 25"
                            class="img-responsive lazyload full"
                            width="536"
                            height="536"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/3/1b/31b71a90-6ebc-11ea-be18-2f3a8c681cd4/5e7b91c7a3452.image.jpg?crop=536%2C536%2C107%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/image_7eaad414-8351-11ea-a4a6-6bc59605356d.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Palm Harbor nursing facility reports outbreak of coronavirus"
                            class="img-responsive lazyload full"
                            width="1127"
                            height="1127"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/editorial/7/ea/7eaad414-8351-11ea-a4a6-6bc59605356d/5e9e1a478c7e4.image.png?crop=1127%2C1127%2C355%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        
        
        
        
    </div>
</div></section></div><div id="tncms-block-766246" class="tncms-block"><section id="block-766246" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-766246 ">
        <div class="block-title-inner">
            <h4>
                
                Shop Local and Save
                
            </h4>
        </div>
    </div></div><div class="card-bg-color ">
        
            
                <div class="card-panel panel">
                    <div class="panel-body">
            
            <article id="card-showcase-35effe07-af30-5990-bb0d-ba102ade9277" class="clearfix card showcase position-0 odd  tnt-section-eedition">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-35effe07-af30-5990-bb0d-ba102ade9277 media-preview edition-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/eedition/edition_35effe07-af30-5990-bb0d-ba102ade9277.html" class="tnt-asset-link">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="April Coupons"
                            class="img-responsive lazyload full"
                            width="300"
                            height="193"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/eedition/4/b5/4b5af802-e775-5f49-918f-916111f4e722/5e9f28f790573.preview-300.jpg?resize=200%2C129 200w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/eedition/4/b5/4b5af802-e775-5f49-918f-916111f4e722/5e9f28f790573.preview-300.jpg?resize=300%2C193 300w" />
                </a>
                
            </div>
            
        </figure></div>
            </div><div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/eedition/edition_35effe07-af30-5990-bb0d-ba102ade9277.html" class="tnt-asset-link">
        

        
            April Coupons</a></h4></div>
                    
                        <div class="card-lead">
                            <p></p>
                        </div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
                    </div>
                </div>
            
        
    </div></section></div><div id="tncms-block-895069" class="tncms-block"><section id="block-895069" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-895069 ">
        <div class="block-title-inner">
            <h4>
                
                This week's edition
                
            </h4>
        </div>
    </div></div>
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        <article id="card-summary-f438013c-28f7-57b9-ae71-bf0f7cfc5eef" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-f438013c-28f7-57b9-ae71-bf0f7cfc5eef media-preview edition-asset" data-aspect=""><figure class="photo layout-vertical letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/eedition/edition_f438013c-28f7-57b9-ae71-bf0f7cfc5eef.html" class="tnt-asset-link">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Tampa Bay Newspapers | April 23"
                            class="img-responsive lazyload full"
                            width="300"
                            height="552"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/eedition/9/2e/92e2ffbe-b2a3-55bd-9909-c2959bc66468/5ea1a54f0e1ee.preview-300.jpg?resize=200%2C368 200w, https://bloximages.newyork1.vip.townnews.com/tbnweekly.com/content/tncms/assets/v3/eedition/9/2e/92e2ffbe-b2a3-55bd-9909-c2959bc66468/5ea1a54f0e1ee.preview-300.jpg?resize=300%2C552 300w" />
                </a>
                
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/eedition/edition_f438013c-28f7-57b9-ae71-bf0f7cfc5eef.html" class="tnt-asset-link">
        

        
            Tampa Bay Newspapers | April 23</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">To view our latest e-Edition click the image on the left.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
                </div>
            </div>
        
    
    </section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/pinellas_county\/crime_crashes_fire","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-580268" class="tncms-block"><section id="block-580268" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-580268 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/users/admin/contribute/article/">
                
                Submit Your News
                
                    </a>
                
            </h4>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p>We're always interested in hearing about news in our community. Let us know what's going on!</p><a href="/users/admin/contribute/article/">
                <button type="button" class="btn btn-info btn-sm">Go to form</button>
            </a></div>
</article></section></div><div id="tncms-block-580271" class="tncms-block"><section id="block-580271" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-580271 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/site/forms/announcements">
                
                Got An Announcement?
                
                    </a>
                
            </h4>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p>We accept many different kinds of announcements. Just click on the button below and submit a form.</p><a href="/site/forms/announcements">
                <button type="button" class="btn btn-info btn-sm">Go to forms</button>
            </a></div>
</article></section></div><div id="tncms-block-580290" class="tncms-block"><section id="block-580290" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-580290 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/marketplace">
                
                Business Directory
                
                    </a>
                
            </h4>
        </div>
    </div></div><div class="card-panel panel">
    <div class="panel-body">
        <div class="list-group">
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?type=business&amp;keyword=&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=25180000&amp;cat=25180600,25180800,25184700,25186600,25183000,25185900,25181900,25184200,25182400,25188600,2518670,25181300,25186000,25184400,25181700,25185200,2518300&amp;radius=15&amp;zipcode=33772">Apparel</a></h4>
                <p class="list-group">
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=25180000&amp;cat=25181300&amp;radius=15&amp;zipcode=33772">Women's Clothing,</a> 
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=25180000&amp;cat=25180800&amp;radius=15&amp;zipcode=33772">Clothing Stores, </a>
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=25180000&amp;cat=25182400&amp;radius=15&amp;zipcode=33772">Shoes</a>...
                </p>
            </div>
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?action=srch&amp;keyword=automotive&amp;radius=15&amp;zipcode=33772">Automotive</a></h3>
                <p class="list-group">
                    <a href="/marketplace/?action=srch&amp;keyword=new+cars&amp;radius=15&amp;zipcode=33772">New Cars</a>,
                    <a href="/marketplace/?sic=21060200&amp;type=business&amp;action=srch&amp;radius=15&amp;zipcode=33772">Used Cars</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=auto+parts&amp;radius=15&amp;zipcode=33772">Auto Parts</a>,
                    <a href="/marketplace/?parent=21000000&amp;cat=21020000&amp;type=business&amp;action=srch&amp;radius=15&amp;zipcode=33772">Auto Repair</a>...
                </p>
            </div>
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?action=srch&amp;keyword=computers&amp;radius=15&amp;zipcode=33772">Computers</a> &amp; <a href="/marketplace/?action=srch&amp;keyword=electronics&amp;radius=15&amp;zipcode=33772">Electronics</a></h3>
                <p class="list-group">
                    <a href="/marketplace/?action=srch&amp;keyword=computers&amp;radius=15&amp;zipcode=33772">Computers</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=software&amp;radius=15&amp;zipcode=33772">Software</a>,
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;cat=25040100&amp;radius=15&amp;zipcode=33772">Supplies</a>,
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=25050000&amp;cat=25052000&amp;radius=15&amp;zipcode=33772">Television &amp; Radio</a>...
                </p>
            </div>
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?action=srch&amp;keyword=community+services&amp;radius=15&amp;zipcode=33772">Community Services</a></h3>
                <p class="list-group">
                    <a href="/marketplace/?action=srch&amp;keyword=church&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=12030100&amp;radius=15&amp;zipcode=33772">Churches</a>,
                    <a href="/marketplace/?sic=12010700&amp;type=business&amp;action=srch&amp;radius=15&amp;zipcode=33772">Libraries</a>,
                    <a href="/marketplace/?type=business&amp;keyword=post+office&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;radius=15&amp;zipcode=33772">Post Offices</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=school&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=14000000&amp;radius=15&amp;zipcode=33772">Schools</a>...
                </p>
            </div>
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?action=srch&amp;keyword=dining&amp;radius=15&amp;zipcode=33772">Dining</a> &amp; <a href="/marketplace/?action=srch&amp;keyword=entertainment&amp;radius=15&amp;zipcode=33772">Entertainment</a></h3>
                <p class="list-group">
                    <a href="/marketplace/?action=srch&amp;keyword=book+store&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=25180300&amp;radius=15&amp;zipcode=33772">Book Stores</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=art+gallery&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=12010000&amp;radius=15&amp;zipcode=33772">Galleries</a>,
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;cat=25060200&amp;radius=15&amp;zipcode=33772">Movie Theaters</a>,
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=27000000&amp;cat=27040000&amp;radius=15&amp;zipcode=33772">Tours</a>,
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=27000000&amp;cat=27030000&amp;radius=15&amp;zipcode=33772">Tourist Attractions</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=restaurants&amp;radius=15&amp;zipcode=33772">Restaurants</a>...
                </p>
            </div>
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?action=srch&amp;keyword=health&amp;radius=15&amp;zipcode=33772">Health</a></h3>
                <p class="list-group">
                    <a href="/marketplace/?action=srch&amp;keyword=dentist&amp;radius=15&amp;zipcode=33772">Dentists</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=hospitals&amp;radius=15&amp;zipcode=33772">Hospitals</a>,
                    <a href="/marketplace/?parent=18030000&amp;cat=18031400&amp;type=business&amp;action=srch&amp;radius=15&amp;zipcode=33772">Optometrists</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=pharmacies&amp;radius=15&amp;zipcode=33772">Pharmacies</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=physicians+surgeons&amp;radius=15&amp;zipcode=33772">Physicians &amp; Surgeons</a>...
                </p>
            </div>
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?action=srch&amp;keyword=real+estate&amp;radius=15&amp;zipcode=33772">Real Estate</a></h3>
                <p class="list-group">
                    <a href="/marketplace/?parent=24030000&amp;cat=24030300&amp;type=business&amp;action=srch&amp;radius=15&amp;zipcode=33772">Apartments</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=lawn+and+garden+supply&amp;sort=name&amp;x=25&amp;y=7&amp;advancedFormState=off&amp;action=srch&amp;parent=10120000&amp;radius=15&amp;zipcode=33772">Landscaping</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=lawn+and+garden+supply&amp;sort=name&amp;x=25&amp;y=7&amp;advancedFormState=off&amp;action=srch&amp;parent=10130000&amp;radius=15&amp;zipcode=33772">Lawn &amp; Garden Supply</a>,
                    <a href="/marketplace/?sic=26024200&amp;type=business&amp;action=srch&amp;radius=15&amp;zipcode=33772">Movers</a>...						
                </p>
            </div>
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?action=srch&amp;keyword=hotels&amp;radius=15&amp;zipcode=33772">Hotels</a> &amp; <a href="/marketplace/?action=srch&amp;keyword=travel&amp;radius=15&amp;zipcode=33772">Travel</a></h3>
                <p class="list-group">
                    <a href="/marketplace/?action=srch&amp;keyword=airline&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=26030100&amp;radius=15&amp;zipcode=33772">Airlines</a>,
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;cat=26060100&amp;radius=15&amp;zipcode=33772">Auto Rental</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=hotels&amp;radius=15&amp;zipcode=33772">Hotels</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=travel+agencies&amp;radius=15&amp;zipcode=33772">Travel Agencies</a>...
                </p>
            </div>
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?action=srch&amp;keyword=money&amp;radius=15&amp;zipcode=33772">Money</a> &amp; <a href="/marketplace/?action=srch&amp;keyword=law&amp;radius=15&amp;zipcode=33772">Law</a></h3>
                <p class="list-group">
                    <a href="/marketplace/?action=srch&amp;amp;type=cat&amp;keyword=accounting&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=15013500&amp;radius=15&amp;zipcode=33772">Accountants</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=attorneys&amp;radius=15&amp;zipcode=33772">Attorneys</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=banks&amp;radius=15&amp;zipcode=33772">Banks</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=insurance&amp;radius=15&amp;zipcode=33772">Insurance</a>...
                </p>
            </div>
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?action=srch&amp;keyword=shops&amp;radius=15&amp;zipcode=33772">Shops</a> &amp; <a href="/marketplace/?action=srch&amp;keyword=services&amp;radius=15&amp;zipcode=33772">Services</a></h3>
                <p class="list-group">
                    <a href="/marketplace/?action=srch&amp;keyword=books+magazines+music+video&amp;radius=15&amp;zipcode=33772">Books, Magazines, Music &amp; Video</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=dry+cleaners&amp;radius=15&amp;zipcode=33772">Dry Cleaners</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=florist&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;parent=25070200&amp;radius=15&amp;zipcode=33772">Florists</a>,
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;cat=24021701&amp;radius=15&amp;zipcode=33772">Shopping Centers &amp; Malls</a>...
                </p>
            </div>
            <div class="list-group-item"><h4 class="list-group-item-heading"><a href="/marketplace/?action=srch&amp;keyword=sports&amp;sort=name&amp;x=13&amp;y=6&amp;advancedFormState=off&amp;action=srch&amp;parent=12020200&amp;radius=15&amp;zipcode=33772">Sports</a> &amp; <a href="/marketplace/?action=srch&amp;keyword=recreation&amp;radius=15&amp;zipcode=33772">Recreation</a></h3>
                <p class="list-group">
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=0&amp;y=0&amp;advancedFormState=off&amp;action=srch&amp;cat=25061400&amp;radius=15&amp;zipcode=33772">Public Golf Courses</a>,
                    <a href="/marketplace/?action=srch&amp;keyword=health+clubs&amp;radius=15&amp;zipcode=33772">Health Clubs</a>,
                    <a href="/marketplace/?type=business&amp;sort=name&amp;x=10&amp;y=2&amp;advancedFormState=off&amp;action=srch&amp;cat=25182600&amp;radius=15&amp;zipcode=33772">Sporting Goods</a>,
                </p>
            </div>
        </div>
    </div>
</div>
</section></div><div id="tncms-block-580206" class="tncms-block"></div><div id="tncms-block-580299" class="tncms-block"></div><div id="tncms-block-580241" class="tncms-block"></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/pinellas_county\/crime_crashes_fire","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div><div id="insticator-container" style="position:relative;margin-left:auto;margin-right:auto;width:300px;margin-bottom:40px;">
                    <div id="div-insticator-ad-1"></div>
                    <div id="insticator-embed"></div>
                    <div id="div-insticator-ad-2"></div>
                </div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-580205" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile2" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"2","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-580204" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-580302" class="tncms-block"><section id="block-580302" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-580302 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pinellas-county"  href="/pinellas_county/" >
                    <span class="nav-label">Pinellas County</span>
                </a></li><li>
                <a class="nav-link  tnt-section-beaches"  href="/beach_beacon/" >
                    <span class="nav-label">Beaches</span>
                </a></li><li>
                <a class="nav-link  tnt-section-greater-belleair"  href="/belleair_bee/" >
                    <span class="nav-label">Greater Belleair</span>
                </a></li><li>
                <a class="nav-link  tnt-section-largo"  href="/largo_leader/" >
                    <span class="nav-label">Largo</span>
                </a></li><li>
                <a class="nav-link  tnt-section-seminole"  href="/seminole_beacon/" >
                    <span class="nav-label">Seminole</span>
                </a></li><li>
                <a class="nav-link  tnt-section-north-county"  href="/north_county/" >
                    <span class="nav-label">North County</span>
                </a></li><li>
                <a class="nav-link  tnt-section-more-local-content"  href="/local_news/" >
                    <span class="nav-label">More Local Content</span>
                </a></li><li>
                <a class="nav-link  tnt-section-diversions"  href="/diversions/" >
                    <span class="nav-label">Diversions</span>
                </a></li><li>
                <a class="nav-link  tnt-section-announcements"  href="/announcements/" >
                    <span class="nav-label">Announcements</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-multimedia"  href="/multimedia/" >
                    <span class="nav-label">Multimedia</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-features"  href="/online_features/" >
                    <span class="nav-label">Online Features</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-580253" class="tncms-block"><section id="block-580253" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-580253 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-submission-forms"  href="/site/forms/" >
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-place-an-ad"  href="/place_an_ad/" >
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link  tnt-section-business-directory"  href="/marketplace/" >
                    <span class="nav-label">Business Directory</span>
                </a></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar/" >
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/search/" >
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-580304" class="tncms-block"><section id="block-580304" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-580304 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>tbnweekly.com</strong><br>
    9911 Seminole Boulevard<br>
    Seminole, FL 33772
    <br>
    
        <strong>Phone:</strong> 727-397-5563<br>
        <strong>Email:</strong> <a href="mailto:webmaster@tbnweekly.com">webmaster@tbnweekly.com</a><br>
    
</address></section></div><div id="tncms-block-580312" class="tncms-block padding-bottom"><div class="follow-links-580312 default">
    
    <section id="block-580312" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-580312 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/TBNweekly/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/TBNwebmaster/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.tbnweekly.com",
  "sameAs" : ["https://www.facebook.com/TBNweekly/","http://twitter.com/TBNwebmaster/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-580257" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-580257"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">TBNweekly</a>, 9911 Seminole Boulevard Seminole, FL</small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/tbnweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/pinellas_county\/crime_crashes_fire","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("6aff68ee-85a4-11ea-a5b1-af4fa4f9ded0")});});
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ (function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: '3.0', q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/b1ad8512-0208-404a-8bef-42066664235a.js');
                /*&lt;![CDATA[[*/Insticator.ad.loadAd('div-insticator-ad-1');Insticator.ad.loadAd('div-insticator-ad-2');Insticator.load('em',{id:'40c1ddd3-f53e-4cc2-99cf-8551b04a81fa'})/*]]&gt;*/ /*]]>*/</script></body>
</html>